$re = '/^([a-z][\w-]{0,255}\.)*([a-z][\w-]{2,255}\.)(gov|edu|mil)(\.[a-z]{2})?$/';
$str = 'b2.a1.a21.edu.tr';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);