re = /^([a-z][\w-]{0,255}\.)*([a-z][\w-]{2,255}\.)(gov|edu|mil)(\.[a-z]{2})?$/
str = 'b2.a1.a21.edu.tr'
# Print the match result
str.match(re) do |match|
puts match.to_s
end