#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)[jJ]o\w+\s[A-Z]*|S\w+"
Local $sString = "John Smith" & @CRLF & _
"Jon Smythe" & @CRLF & _
"John Smythe" & @CRLF & _
"Jon Smith" & @CRLF & _
"John Smth" & @CRLF & _
"jon Smith" & @CRLF & _
"jon B. Smith" & @CRLF & _
"Peter Finch" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")