package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[jJ]o\w+\s[A-Z]*|S\w+`)
var str = `John Smith
Jon Smythe
John Smythe
Jon Smith
John Smth
jon Smith
jon B. Smith
Peter Finch
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}