// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)[jJ]o\w+\s[A-Z]*|S\w+").unwrap();
let string = "John Smith
Jon Smythe
John Smythe
Jon Smith
John Smth
jon Smith
jon B. Smith
Peter Finch
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}