using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[jJ]o\w+\s[A-Z]*|S\w+";
string input = @"John Smith
Jon Smythe
John Smythe
Jon Smith
John Smth
jon Smith
jon B. Smith
Peter Finch
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}