$re = '/[jJ]o\w+\s[A-Z]*|S\w+/mi';
$str = 'John Smith
Jon Smythe
John Smythe
Jon Smith
John Smth
jon Smith
jon B. Smith
Peter Finch
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);