re = /[jJ]o\w+\s[A-Z]*|S\w+/mi
str = 'John Smith
Jon Smythe
John Smythe
Jon Smith
John Smth
jon Smith
jon B. Smith
Peter Finch
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end