# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/''|(')/''/g;t' <<< "You're Doing It Wrong!!,'''Mike Walsh'',Intermediate"