re = /''|(')/
str = 'You\'re Doing It Wrong!!,\'\'\'Mike Walsh\'\',Intermediate'
subst = '\'\''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result