use strict;
my $str = 'You\'re Doing It Wrong!!,\'\'\'Mike Walsh\'\',Intermediate';
my $regex = qr/''|(')/p;
my $subst = '\'\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";