#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\S)[^а-яА-Я\s]+(?!\S)"
Local $sString = " des поместья, de la famille Buonaparte. Non, je vous préviens que si vous поместья поместья test поместья" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)