use strict;
my $str = ' des поместья, de la famille Buonaparte. Non, je vous préviens que si vous поместья поместья test поместья
';
my $regex = qr/(?<!\S)[^а-яА-Я\s]+(?!\S)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";