import Foundation
let pattern = #"(?<!\S)[^а-яА-Я\s]+(?!\S)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
des поместья, de la famille Buonaparte. Non, je vous préviens que si vous поместья поместья test поместья
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)