using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)[^а-яА-Я\s]+(?!\S)";
string substitution = @"";
string input = @" des поместья, de la famille Buonaparte. Non, je vous préviens que si vous поместья поместья test поместья
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}