re = /(?<!\S)[^а-яА-Я\s]+(?!\S)/m
str = ' des поместья, de la famille Buonaparte. Non, je vous préviens que si vous поместья поместья test поместья
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result