$re = '/(?<!\S)[^а-яА-Я\s]+(?!\S)/m';
$str = ' des поместья, de la famille Buonaparte. Non, je vous préviens que si vous поместья поместья test поместья
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;