package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^ # New line
T?([00-23]{2}) # Hour block (00 through 23 hours)
\:?([00-59]{2}) # Minute block (00 through 59 minutes)
\s* # Optional space
([ap])?\.?(m?)\.? # AM or PM, with or without periods
$ # End of the string.`)
var str = `T12:34
12:34
12:34PM
1000
12:34AM
12:34 AM
12:34 PM
12:34 A.M
12:34 P.M
23:59
23:59 PM
55:88 PM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}