import Foundation
let pattern = ##"""
^ # New line
T?([00-23]{2}) # Hour block (00 through 23 hours)
\:?([00-59]{2}) # Minute block (00 through 59 minutes)
\s* # Optional space
([ap])?\.?(m?)\.? # AM or PM, with or without periods
$ # End of the string.
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
T12:34
12:34
12:34PM
1000
12:34AM
12:34 AM
12:34 PM
12:34 A.M
12:34 P.M
23:59
23:59 PM
55:88 PM
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)