import re
regex = re.compile(r"""
^ # New line
T?([00-23]{2}) # Hour block (00 through 23 hours)
\:?([00-59]{2}) # Minute block (00 through 59 minutes)
\s* # Optional space
([ap])?\.?(m?)\.? # AM or PM, with or without periods
$ # End of the string.
""", flags=re.IGNORECASE | re.MULTILINE | re.VERBOSE)
test_str = ("T12:34\n"
"12:34\n"
"12:34PM\n"
"1000\n"
"12:34AM\n"
"12:34 AM\n"
"12:34 PM\n"
"12:34 A.M\n"
"12:34 P.M\n"
"23:59\n"
"23:59 PM\n"
"55:88 PM")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")