// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?imx)^ # New line
T?([00-23]{2}) # Hour block (00 through 23 hours)
\:?([00-59]{2}) # Minute block (00 through 59 minutes)
\s* # Optional space
([ap])?\.?(m?)\.? # AM or PM, with or without periods
$ # End of the string.").unwrap();
let string = "T12:34
12:34
12:34PM
1000
12:34AM
12:34 AM
12:34 PM
12:34 A.M
12:34 P.M
23:59
23:59 PM
55:88 PM";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}