import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ # New line\n"
+ "T?([00-23]{2}) # Hour block (00 through 23 hours)\n"
+ "\\:?([00-59]{2}) # Minute block (00 through 59 minutes)\n"
+ "\\s* # Optional space\n"
+ "([ap])?\\.?(m?)\\.? # AM or PM, with or without periods\n"
+ "$ # End of the string.";
final String string = "T12:34\n"
+ "12:34\n"
+ "12:34PM\n"
+ "1000\n"
+ "12:34AM\n"
+ "12:34 AM\n"
+ "12:34 PM\n"
+ "12:34 A.M\n"
+ "12:34 P.M\n"
+ "23:59\n"
+ "23:59 PM\n"
+ "55:88 PM";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}