const regex = /^ # New line
T?([00-23]{2}) # Hour block (00 through 23 hours)
\:?([00-59]{2}) # Minute block (00 through 59 minutes)
\s* # Optional space
([ap])?\.?(m?)\.? # AM or PM, with or without periods
$ # End of the string./img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ # New line
T?([00-23]{2}) # Hour block (00 through 23 hours)
\\:?([00-59]{2}) # Minute block (00 through 59 minutes)
\\s* # Optional space
([ap])?\\.?(m?)\\.? # AM or PM, with or without periods
$ # End of the string.', 'img')
const str = `T12:34
12:34
12:34PM
1000
12:34AM
12:34 AM
12:34 PM
12:34 A.M
12:34 P.M
23:59
23:59 PM
55:88 PM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}