# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d\h*-\h*(*SKIP)(*F)|-(?!\h*\d)/ /g;t' <<< "Al-Abbas - Manama - 100
100 - foo"