re = /\d\h*-\h*(*SKIP)(*F)|-(?!\h*\d)/
str = 'Al-Abbas - Manama - 100
100 - foo'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result