import Foundation
let pattern = #"\d\h*-\h*(*SKIP)(*F)|-(?!\h*\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Al-Abbas - Manama - 100
100 - foo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)