using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d\h*-\h*(*SKIP)(*F)|-(?!\h*\d)";
string substitution = @" ";
string input = @"Al-Abbas - Manama - 100
100 - foo";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}