use strict;
my $str = 'Al-Abbas - Manama - 100
100 - foo';
my $regex = qr/\d\h*-\h*(*SKIP)(*F)|-(?!\h*\d)/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";