using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"TimesAccessed[[:punct:]]+(?<TimesAccessed>[^\"",]+)";
string input = @"Message: PublicDomainAPI.SaveAsync: progresses = [{""UserGuid"":""0a062514-def3-4ae5-9092-asd12easd"",""CourseId"":""c71f6538-e379-447e-aaf3-asd1dasd"",""Status"":""InProgress"",""UserScore"":1,""TotalTime"":""0:23:45"",""TimesAccessed"":null,""CompletionDate"":null,""LastTimeAccessed"":""2022-07-23T09:59:12.191+00:00"",""SuccessStatus"":""Pass"",""Bookmark"":""en"",""SuspendData"":null,""Progress"":null,""RegistrationDate"":""2022-07-23T09:59:12.191+00:00"",""RegistrationNumber"":1}], total: 1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}