// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)TimesAccessed[[:punct:]]+(?<TimesAccessed>[^\",]+)"#).unwrap();
let string = "Message: PublicDomainAPI.SaveAsync: progresses = [{\"UserGuid\":\"0a062514-def3-4ae5-9092-asd12easd\",\"CourseId\":\"c71f6538-e379-447e-aaf3-asd1dasd\",\"Status\":\"InProgress\",\"UserScore\":1,\"TotalTime\":\"0:23:45\",\"TimesAccessed\":null,\"CompletionDate\":null,\"LastTimeAccessed\":\"2022-07-23T09:59:12.191+00:00\",\"SuccessStatus\":\"Pass\",\"Bookmark\":\"en\",\"SuspendData\":null,\"Progress\":null,\"RegistrationDate\":\"2022-07-23T09:59:12.191+00:00\",\"RegistrationNumber\":1}], total: 1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}