import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "TimesAccessed[[:punct:]]+(?<TimesAccessed>[^\\\",]+)";
final String string = "Message: PublicDomainAPI.SaveAsync: progresses = [{\"UserGuid\":\"0a062514-def3-4ae5-9092-asd12easd\",\"CourseId\":\"c71f6538-e379-447e-aaf3-asd1dasd\",\"Status\":\"InProgress\",\"UserScore\":1,\"TotalTime\":\"0:23:45\",\"TimesAccessed\":null,\"CompletionDate\":null,\"LastTimeAccessed\":\"2022-07-23T09:59:12.191+00:00\",\"SuccessStatus\":\"Pass\",\"Bookmark\":\"en\",\"SuspendData\":null,\"Progress\":null,\"RegistrationDate\":\"2022-07-23T09:59:12.191+00:00\",\"RegistrationNumber\":1}], total: 1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}