# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"TimesAccessed[[:punct:]]+(?<TimesAccessed>[^\",]+)"
test_str = "Message: PublicDomainAPI.SaveAsync: progresses = [{\"UserGuid\":\"0a062514-def3-4ae5-9092-asd12easd\",\"CourseId\":\"c71f6538-e379-447e-aaf3-asd1dasd\",\"Status\":\"InProgress\",\"UserScore\":1,\"TotalTime\":\"0:23:45\",\"TimesAccessed\":null,\"CompletionDate\":null,\"LastTimeAccessed\":\"2022-07-23T09:59:12.191+00:00\",\"SuccessStatus\":\"Pass\",\"Bookmark\":\"en\",\"SuspendData\":null,\"Progress\":null,\"RegistrationDate\":\"2022-07-23T09:59:12.191+00:00\",\"RegistrationNumber\":1}], total: 1"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.