package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)TimesAccessed[[:punct:]]+(?<TimesAccessed>[^\",]+)`)
var str = `Message: PublicDomainAPI.SaveAsync: progresses = [{"UserGuid":"0a062514-def3-4ae5-9092-asd12easd","CourseId":"c71f6538-e379-447e-aaf3-asd1dasd","Status":"InProgress","UserScore":1,"TotalTime":"0:23:45","TimesAccessed":null,"CompletionDate":null,"LastTimeAccessed":"2022-07-23T09:59:12.191+00:00","SuccessStatus":"Pass","Bookmark":"en","SuspendData":null,"Progress":null,"RegistrationDate":"2022-07-23T09:59:12.191+00:00","RegistrationNumber":1}], total: 1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}