#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\d+\S+\s+"
Local $sString = "canon 40 22mm lens lock strength plenty orientation 321 ."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)