const regex = /\d+\S+\s+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+\\S+\\s+', 'g')
const str = `canon 40 22mm lens lock strength plenty orientation 321 .`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);