using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+\S+\s+";
string substitution = @"";
string input = @"canon 40 22mm lens lock strength plenty orientation 321 .";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}