$re = '/\d+\S+\s+/';
$str = 'canon 40 22mm lens lock strength plenty orientation 321 .';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;