#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\s*(?:[-><])?\s*\d+(?:[.]\d+)?)+$"
Local $sString = "2.5" & @CRLF & _
"1-15.5" & @CRLF & _
">10" & @CRLF & _
">12.54" & @CRLF & _
"<75" & @CRLF & _
"" & @CRLF & _
"# Works also on" & @CRLF & _
"" & @CRLF & _
">46" & @CRLF & _
"" & @CRLF & _
"12-15" & @CRLF & _
">14.3" & @CRLF & _
"5 - 10" & @CRLF & _
"" & @CRLF & _
"1.5 - 10.3" & @CRLF & _
"< 10" & @CRLF & _
"" & @CRLF & _
"# refuse invalid" & @CRLF & _
"< 10.2." & @CRLF & _
"" & @CRLF & _
"1 - .."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")