$re = '/^(\s*(?:[-><])?\s*\d+(?:[.]\d+)?)+$/m';
$str = '2.5
1-15.5
>10
>12.54
<75
# Works also on
>46
12-15
>14.3
5 - 10
1.5 - 10.3
< 10
# refuse invalid
< 10.2.
1 - ..';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);