package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\s*(?:[-><])?\s*\d+(?:[.]\d+)?)+$`)
var str = `2.5
1-15.5
>10
>12.54
<75
# Works also on
>46
12-15
>14.3
5 - 10
1.5 - 10.3
< 10
# refuse invalid
< 10.2.
1 - ..`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}