import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\s*(?:[-><])?\\s*\\d+(?:[.]\\d+)?)+$";
final String string = "2.5\n"
+ "1-15.5\n"
+ ">10\n"
+ ">12.54\n"
+ "<75\n\n"
+ "# Works also on\n\n"
+ ">46\n\n"
+ "12-15\n"
+ ">14.3\n"
+ "5 - 10\n\n"
+ "1.5 - 10.3\n"
+ "< 10\n\n"
+ "# refuse invalid\n"
+ "< 10.2.\n\n"
+ "1 - ..";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}