import Foundation
let pattern = #"^(\s*(?:[-><])?\s*\d+(?:[.]\d+)?)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
2.5
1-15.5
>10
>12.54
<75
# Works also on
>46
12-15
>14.3
5 - 10
1.5 - 10.3
< 10
# refuse invalid
< 10.2.
1 - ..
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)