const regex = /^(\s*(?:[-><])?\s*\d+(?:[.]\d+)?)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\s*(?:[-><])?\\s*\\d+(?:[.]\\d+)?)+$', 'gm')
const str = `2.5
1-15.5
>10
>12.54
<75
# Works also on
>46
12-15
>14.3
5 - 10
1.5 - 10.3
< 10
# refuse invalid
< 10.2.
1 - ..`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}