using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)_(.*)\.tgz$";
string substitution = @"\1:\2";
string input = @"xyzzz_no_db_20.9.1-82.tgz";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}