const regex = new RegExp('(.*)_(.*)\\.tgz$', 'gm')
const str = `xyzzz_no_db_20.9.1-82.tgz`;
const subst = `\1:\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);