package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)_(.*)\.tgz$`)
var str = `xyzzz_no_db_20.9.1-82.tgz`
var substitution = "\1:\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}