re = /(.*)_(.*)\.tgz$/m
str = 'xyzzz_no_db_20.9.1-82.tgz'
subst = '\\1:\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result