$re = '/(.*)_(.*)\.tgz$/m';
$str = 'xyzzz_no_db_20.9.1-82.tgz';
$subst = "\1:\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;