import Foundation
let pattern = #"(.*)_(.*)\.tgz$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"xyzzz_no_db_20.9.1-82.tgz"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1:\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)