# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\r\n?|\n){2,}/$1/g;t' <<< "Text of example in line 1.
The text is very nice...
The end."